Outlook Engage SharePoint list display not including Date/Time fields

I configured a document library in SharePoint that had the standard field mappings that you recommend with Colligo (Subject, To, To-Address, From, From-Address, Received, Received-UTC, Sent, Sent-UTC, etc.).  When copying an email from my inbox to a Colligo SharePoint folder, the fields are auto-populated as shown here:
image
As shown, the time does not populate for "Sent-UTC," "Received," and "Received-UTC," but it does populate correctly for "Sent."  Why is the time not populating for all 4 fields?
The fields are uploaded to SharePoint for all 4 fields, but again, with only the date and without the time for the "Sent-UTC," "Received," and "Received-UTC," columns:
image
Now, what happens is that in Outlook 2016, when I go to the respective folder in a site in Colligo, we cannot see the columns corresponding to the date/time metadata:
 
image
The question is, why are the date/time fields populating with "None" instead of the values in the metadata columns shown in SharePoint in the browser?  Also, "Received" is being populated with the date/time of the document upload instead of the date/time that the email came in.  
We would like to be able to see the date/time that the original email came in so that we can sort on this field in the Colligo email folder list view.
Thank you in advance for your help!
Best,
Eric


Hi Eric


The sorting order is based on receive date (the date you file that email) not the actual sent & received date on that email. For sorting order on original, you have to switch back to browser mode to do the sorting in SharePoint view. 


Philip

Yes, Philip, those columns are "Date and Time" columns.  The metadata is being captured correctly when I move the email into a Colligo folder.  The problem is that when I am viewing the items inside the Colligo folder, I cannot see the Date and Time columns and their contents.  Because of this, I cannot sort the emails in the Colligo folder by "Sent" or "Received" which is a problem when you have dozens of emails in a Colligo folder.

Thanks,

Eric

Hi Eric


You should not able to see the 4 date columns by default 


image


Do you check if the newly created date and time columns set to "Date and Time" and not just "Date"? Because Date and Time column can set to "Date only" which can be misleading.


Philip





Philip-

I was able to create an Email content type using a function in PowerShell, and I added Sent, Sent-UTC, Received, Received-UTC columns as Date and Time columns and I was still unable to see those columns in the native Outlook view of emails in a Library folder.  I was able to see those new columns from within the web view of Outlook though. 

-Eric

Hi Eric


Can you try create a new columns and add to a new content type? It looks like for some reason, it is only set to a date instead of date and time.


Philip



Hi Philip-

Those columns were set to "Date & Time."

Thanks,

Eric


Hi Eric


It looks like Email content type is not available on your site. For your current library, can you do one quick check on your Sent/Receive columns?


image


Is it set to Date Only or Date & Time?


Thanks


Philip


Philip-

I built a new site, added a new library and enabled management of Content Types on that library.  I do not see "Email" as an available Content Type (not showing the whole list here, but it is not there):

image

Do I need to import the settings for the "Email" Content Type?


Thanks,

Eric



Hi Eric


If you are using O365 the email template should be standard


Can you try again on adding a Email content type to a new site collection / library, it should contain all the necessary columns by default as follow:


image


Hi Kyle-

I am not seeing that the stp file format or any list template for that matter can be uploaded to Office 365.  I am following the Admin guide you have for v7 and there is no similar link to upload a list template in Office 365.  Do you have a workaround?

Thanks,

Eric


Hi Eric


Can you try creating a library using one of the templates in our article here and let us know if you still have the issue. Sharepoint 2016 should take the 2013 template if you are using SP2016 or 0365,


-Kyle

Hi Philip-

I tried to create a fresh Document Library in my site with an Email Content Type.  The default column types for that did not have a "Received" or "Received-UTC" column, so I added those.  I still do not see the date that the email was actually received when I look in the Colligo folder within Outlook.  The only date I see is the date I moved the email into the Colligo folder (today).

Thanks,

Eric


Hi Eric


It looks like a configuration issue for you. Can you try to add a new Email content type to your document library, drag and drop with newly created email content type?


Thanks


Philip

Login or Signup to post a comment